2015年 6月 の投稿一覧

Plesk12がPHPマイナーバージョン全てを選択できるようにした

Pleskのようなコントロールパネルを導入した時、一つ問題になるのがPHPバージョンです。
現在主流はPHPのメジャーバージョン5ですが、この5というバージョンは、マイナーバージョンによって仕様がバラバラ。。。
あのソフトは、5.2で動く、でもこのソフトは5.3以降じゃないとまともに動かないなどほとんどの場合、1つのバージョンで賄えることはありません。
ソフトを使う側のサイトオーナーがそれなりに知識があれば、htaccessや、php.iniの修正で何とかなりますが、ぶっちゃけ、そんなスキルがある方が共用サーバーを使うことも少ないですし、そもそも、問題になることってあまりありませんよね。

続きを読む